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Introduction 
This comprehensive migration guide explains the steps for FirstClass users to migrate to Microsoft 
Outlook (email, calendar and contacts) and Office 365 (documents, files and conferences). While 
instructions have been provided to transfer calendars, contacts and mailing lists it is recommended 
these only be attempted if there are too many entries to make re-entering them in Outlook infeasible.  
Ideally most users will only transfer emails and documents.   

 

Hopefully this guide is sufficiently clear for FirstClass users to complete the migration themselves.  Users 
needing technical assistance may open a helpdesk ticket (helpdesk@dawsoncollege.qc.ca) requesting 
such assistance. 

 

Comments regarding this document can be emailed to Derek Gaucher (dgaucher@dawsoncollege.qc.ca)  

 

 

  

mailto:helpdesk@dawsoncollege.qc.ca
mailto:dgaucher@dawsoncollege.qc.ca
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Transferring FirstClass Mail to Microsoft Outlook 
 
 
Step 0: Preparing for migration 
    

1. Email the computer helpdesk (helpdesk@dawsoncollege.qc.ca) with the 
subject “FirstClass Migration”.  Request the email forwarding rule for FirstClass 
the Outlook mailbox quota be removed.  You will receive an email from the 
helpdesk confirming this step was completed. 

2. Email mlazarevic@dawsoncollege.qc.ca requesting your email address in the 
telephone directory by changed to yourname@dawsoncollege.qc.ca 

3. Login to First Class, the same way you always have.  
4. Check the settings in Edit > Preferences > Messaging > Mail Rules and make 

sure all reply and forwarding is set to No except for Local mail forwarding is 
set to Yes.   Enter your dawsoncollege.qc.ca email address in the Forward to: 
box.  (This rule will allow you to continue to receive mail from colleagues still 
using FirstClass).    

 

mailto:helpdesk@dawsoncollege.qc.ca
mailto:mlazarevic@dawsoncollege.qc.ca
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Step 1: Your FirstClass mailbox 
 

1. Only incoming and outgoing emails and their folders will be transferred.  
Drafts, deleted and junk emails will not be transferred.   

2. Delete any old emails that you do not want to transfer to Outlook. 
3. Exit/Quit FirstClass 

 
 
Step 2: Setup Microsoft Outlook with your dawsoncollege.qc.ca email account if 
you have never installed Outlook. 
 
Setup instructions can be found on the college website in the Email User Guide. 
 
 
Step 3: Launch the email migration tool 

1. Using Windows Search programs and files enter “Remote Desktop 
Connection” 

 

2. Click on “Remote Desktop Connection” under Programs 

 

 

 

 

 

https://www.dawsoncollege.qc.ca/public/72b18975-8251-444e-8af8-224b7df11fb7/services/isit/documents/email_user_guide.pdf
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3. In the box labelled Computer enter ts2012farm.dawsoncollege.qc.ca and 
click the Connect button.   

 

4. Enter your Dawson network password 

 

5. Click the Yes button to acknowledge the certificate warnings.
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6. Click the “D” icon on the desktop to open the FirstClass Migration Tool

 
 

7. Enter your information 
• Enter your FirstClass username and password in the FirstClass section 
• Enter your Dawson network login name and password in the Webmail 

section 
• Note: The migration duration is dependent on the number of 

FirstClass emails being migrated.  This may range from a few minutes 
to hours.   Unfortunately, the migration tool does not display a 
progress bar or time to completion estimate.   Please be patient and 
leave the tool run until completion.    

• Click the Migrate button. 
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8. Read the information box and click OK to continue. 

 

 

9. Upon completion the log file will be displayed along with an information box 
indicating the process was a success.   Click OK to close the information box 
and close the migration tool screen by clicking the “X” in the top right hand 
corner. 
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Note: If your migration fails then please send an email to 
helpdesk@dawsoncollege.qc.ca with a screenshot of any error message and 
subject “FirstClass migration problem”. 

 

 
 
 
 
Step 4- Verify emails and email folders were migrated correctly 

1. Using either the Microsoft Outlook desktop application or Outlook Webmail 
App spot check your emails and email folders to confirm the migration was 
successful. 

mailto:helpdesk@dawsoncollege.qc.ca
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Note: Please report problems to helpdesk@dawsoncollege.qc.ca with the subject 
“FirstClass migration problem” and an explanation of the problem. 

 

 

 

 

 

 

  

mailto:helpdesk@dawsoncollege.qc.ca
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Transferring Documents / Files 
 
Office 365 provides two options for storing files: OneDrive for Business (OneDrive) 
and SharePoint.   

When to save documents to OneDrive 
• You don’t plan to share them. Documents you place in OneDrive are private 

by default, unless you place them in the Shared with Everyone folder. This 
makes OneDrive your best option for draft documents or personal documents 
that no one else needs to see. 

• You plan to share files individually and with a limited scope or lifecycle. 
For example, you’re writing a blog post that may not be associated with a 
project, and you’d like a few colleagues to review it before you post it. In this 
case, you expect people to use the document once without needing 
additional storage or context information. All they need is a link to the 
document and editing permission. 

When to save documents to a SharePoint library 
• The document is to be shared with multiple people on an ongoing basis. 
• You want access and editing permissions to be granted on a site basis, 

instead of on individual documents. If people have access to the SharePoint 
site, then they have access to documents stored in the site. 

• Other related documents are already stored in the SharePoint library, and 
other people expect to find it there.  

For assistance to create a department or program SharePoint site please contact 
Katerina (etsakoumagou@dawsoncollege.qc.ca) – SharePoint Analyst, IT Solutions 

 

1. Download or drag and drop the FirstClass documents / files to your computer 
desktop or file folder. 

2. Sign in to Office 365 and upload your documents to either OneDrive or the 
appropriate SharePoint site (department, program, etc.).   

 
  

https://support.office.com/en-us/article/share-files-1fe37332-0f9a-4719-970e-d2578da4941c
mailto:etsakoumagou@dawsoncollege.qc.ca
https://login.microsoftonline.com/
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Transferring FirstClass Contacts to Outlook People 
 
Step 1: Exporting from FirstClass 
NOTE: Mailing Lists for multiple individuals cannot be exported using this method. 
See next section “How to Move Your Mail List Contacts from FirstClass to 
Outlook”. 

• From within FirstClass, open your Contacts. 
• Choose File > Export. 
• Click on Selected contacts or All contacts for export, whichever is 

appropriate. 
• Choose For use with Outlook (.csv) as the export format. 

                 

• Select the location (your Desktop) where you want the file to be saved and 
click Save 

• The transfer window will appear. If you have mail lists with multiple 
individuals, you will receive the following warning message indicating these 
items were skipped during the export. 

                 
 

• Click close and your contacts are now exported. 
 

http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.7/2232015_53407_0.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.8/2232015_53616_1.png
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Step 2: Review the .CSV spreadsheet in Excel before importing contacts into 
Office 365 

• Make sure that all of the values for “email address” contain only the email 
address and not the first and last name of the person as well). 

• Delete the row of any email address that has ,Internet 
• Make sure that the names of your contacts are placed in the correct columns 

for First Name and Last Name. 

Sample Excel .csv export file 

         
• Save the spreadsheet. Click Yes to keep the .CSV format. 

         
 
Step 3: Import Contacts to Outlook 2013 

• From within Outlook, Click File > Open & Export > Import/Export.  This 
starts the Import and Export Wizard. 

• Choose Import from another program or file, and then click Next. 

                 
• Under Select the file type to import, choose Comma Separated 

Values and then click Next. 
• Browse to the .csv file you want to import (created in Step 1). 

Under Options, choose whether to replace duplicates (existing contacts), 
create duplicate contacts, or not import duplicates. Click Next. 

http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.9/2232015_55015_2.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.0/2232015_52407_2.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.1/2232015_52407_3.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.3/2232015_52407_6.png
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• Choose the destination folder for your contacts. Contacts should be selected 

by default, but if it's not, scroll up or down until you find it. Click Next. 

         
• Make sure the check box next to Import "MyContacts.csv" (assuming 

that's your file name) is selected. Click Finish. 

         
Your contacts are now imported. 
 

 

 

 

 

  

http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.4/2232015_52407_7.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.5/2232015_52407_8.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870B14-00870BC8.6/2232015_52407_9.png
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How to Move Your Mail List Contacts from FirstClass to Outlook 

• This document will show you how to copy some of your Mail Lists from 
FirstClass to Outlook. 

• This document explains how to move over your Mail Lists. Moving over your 
Individual Contacts should be done before moving your Mail Lists, in a 
separate process (which is explained in the preceding section of this 
document). 

• From within FirstClass, open you’re Contacts. Click to select the mailing 
list you wish to export. 

 
• Right-click on the icon and select “Summarize Selected” from the drop-

down menu. 

 
• A new window will appear with a list of e-mail addresses that you have 

associated with the mail list. Highlight the list of addresses and copy 
them. 

 
• Open Outlook Desktop App and click on the “People”. Then click on the 

“New Contact Group” icon in the upper left hand corner. 

http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870CD4-00870BC8.1/C:/Users/CHRIST%7E1/AppData/Local/Temp/SNAGHTML13902cc.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870CD4-00870BC8.0/792015_24647_12.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870CD4-00870BC8.2/792015_42218_0.png
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• Type the desired name for your group into “Name” field of the new contact 

group window that opens. Click on the “Add Members” button and select 
“From Address Book” from the menu that appears. 

 
• In the “Select Members: Global Address List” window that appears, click 

in the white space to the right of the “Members” button, and 
press “Ctrl” and “V"or right click and paste to add the list of members that 
you copied from the mailing list. 

 
• Once you have finished click the “OK” button. You will see a list of all the 

contacts. 
 

Click the “Save and Close” button in the top left corner to save your work. 

  

http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870CD4-00870BC8.3/792015_42414_1.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870CD4-00870BC8.4/792015_50142_2.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/10870CD4-00870BC8.5/792015_50324_3.png


FirstClass Migration Guide 
Adapted from documentation prepared by the Limestone District Schoolboard 
Prepared: October 2016 
 

16 
 

Transferring FirstClass Calendar to Outlook Calendar 

Note: Transferring your calendar is not recommended.  It is better to re-enter your 
appointments into Outlook 

• You must use a Windows computer (desktop/laptop) that has Outlook 2013 
to import the calendar that was exported from FirstClass. This procedure 
cannot be accomplished using the Outlook Web App (OWA). 

• Due to some shortcomings in Outlook 2011 for Apple Mac, even if your Mac 
has Outlook 2011 on it, you must use a Windows computer with Outlook 
2013 and FirstClass in order to transfer your calendar. 

• FirstClass only exports the first entry in the series of recurring events. Only 
the first event in the series will be imported into your Outlook calendar.  This 
means that you will need to manually recreate the recurrences (daily, 
monthly, etc.) and resend invitations to the list of attendees (if any). 

• Remove all punched through calendars. A Punch-through calendar, is an 
overlay calendar. 

Step 1: Identify Recurring Calendar Entries in FirstClass 

• From within FirstClass, open your calendar.  Click on View > View by 
List. 

         
• If a meeting is recurring, you will be able to see this in the Repeat Interval 

column.  If there is anything other than 'None' in this column, only the first 
event will export. 

 
 
Step 2: Identify and remove all punched through calendars 

• From within FirstClass, click on View > Show Today List.               

• Click the Calendar tab and Remove the check mark from all pushed 
through calendars. Now you are ready to export. 

http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/107FC225-00870BC8.3/2172015_24034_0.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/107FC225-00870BC8.4/2172015_25940_0.png
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Step 3: Export 
The export does not remove or alter any events/meetings on your FirstClass calendar. 

• From within FirstClass, open your calendar.   
• Choose File > Export. 
• Under Export Calendar, select on iCalendar (.ics), and click OK.         

         
• Select the location where you want the file to be saved and click Save. The 

transfer window will appear. 

         
Step 4: Import to Outlook Calendar 

• Launch Outlook 2013 from a computer (desktop/ laptop) not from a web 
browser. 

• Click File > Open & Export > Import/Export.  This starts the Import and 
Export Wizard. 

• Choose Import an iCalendar (.ics) and then click Next. 

         
• Browse to the .ics file you want to import (created in Step 3) and click Ok. 
• Select if you wish to Open as New calendar or Import the entries into 

your current Outlook calendar.  Import would be the normal selection, unless 
you are creating a new calendar.      

http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/107FC225-00870BC8.5/file:/C:/Users/CHRIST%7E1.LDS/AppData/Local/Temp/SNAGHTMLef.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/107FC225-00870BC8.0/2172015_121623_4.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/107FC225-00870BC8.1/2172015_121623_5.png
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/107FC225-00870BC8.6/file:/C:/Users/CHRIST%7E1.LDS/AppData/Local/Temp/SNAGHTML15.png
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A box will open up showing you the progress of your import.  When it is complete, 
you will see your calendar with the new entries added.  If you chose a new 
calendar, you will see all your calendars side by side. Each calendar is a different 
colour to allow you to distinguish between them. 
 
Note: Your OWA calendar does not display the events after the import. To 
get around this, add a new event or edit an event on the Outlook 2013 
calendar. 
Watch online 
  
  

https://www.youtube.com/watch?v=YFOX5NrJgGY
http://myits.limestone.on.ca/Office_365/Firstclass_Outlook/107FC225-00870BC8.2/2172015_121623_7.png
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Recreating FirstClass Conferences using Yammer 
FirstClass conferences are proprietary to FirstClass and there are no tools available to convert them to 
other platforms.   Replacement conferences can be created using the Office 365 Yammer application. 

 

Migrating FirstClass Conference Emails 
Conference owners can migrate emails associated with their conferences by right clicking the 
conference folder and selecting “Add to desktop”.   
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From the desktop, click on the folder and drag it to the MailBox. 

 

 

The conference folder should appear as a folder under the MailBox. 

 

 

The migration tool will transfer the conference emails to an Outlook Inbox subfolder.  The migration tool 
will not transfer conference documents and will display error messages stating this fact.    
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Migrating FirstClass Conference Files 
1. Create a folder on your Windows desktop. 
2. Open the FirstClass conference file folder to be migrated 
3. Select the files to be migrated 
4. Drag the files from FirstClass to the desktop folder created in step 2 
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5. Login into Office 365 
6. Click on OneDrive 
7. Click on New and select Folder 
8. Enter the folder name 
9. Click on the folder to open it. 
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10. To move the files from your desktop folder to OneDrive you either click Upload on the OneDrive 
page and select the files to be uploaded or open the desktop folder, select the files to be 
uploaded, then drag and drop the files on the OneDrive page. 
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Example of opening the desktop file folder, selecting the files to be migrated the drag and drop to Office 
365 OneDrive page. 
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